AccueilActualités informatiqueDroits d'accès root grâce à une faille dans le système de distribution...

Droits d’accès root grâce à une faille dans le système de distribution de logiciels Snap

Des failles de sécurité dans le système de distribution de logiciels Snap pourraient être utilisées abusivement par des attaquants pour obtenir des droits root dans le système – par exemple dans la configuration standard d’Ubuntu sur le bureau. Snap permet aux utilisateurs d’installer des paquets logiciels spécialement préparés, qui sont par exemple plus actuels que les versions natives des sources de paquets de la distribution. Pour cela, Snap fournit un environnement avec des bibliothèques d’exécution et des couches de séparation afin que de tels paquets logiciels ne puissent pas endommager le système.

Sommaire

Des attaquants pourraient utiliser des déclarations d’interface de contenu et de mise en page préparées dans des bundles Snap pour introduire des règles AppArmor arbitraires et ainsi s’affranchir des restrictions de droits de Snap (CVE-2021-4120, CVSS 8.2, risque élevé). De plus, ils pourraient obtenir les droits root en créant un lien dur à partir de l’exécutable snap-confine vers un fichier binaire quelconque, car le service Snap ne vérifie pas correctement l’endroit d’où ce fichier est lancé (CVE-2021-44730, CVSS 7.8, haut). Le même effet a été obtenu par ce que l’on appelle une condition de race en snap-confine si des attaquants avaient intégré leur propre contenu lors de la préparation d’un espace de noms de montage privé par Snap (CVE-2021-44731, CVSS 7.8, haut).

Une autre vulnérabilité à faible risque était que les anciennes versions de Snap ne définissaient pas les droits d’accès au répertoire ~/snap de manière suffisamment restrictive, ce qui aurait pu permettre à des personnes non autorisées de lire des informations (CVE-2021-3155, CVSS 3.8, bas). Dans un communiqué de sécurité, Qualys, une entreprise de sécurité informatique, décrit de manière très détaillée comment les chercheurs ont découvert les deux failles permettant d’étendre ses propres droits à la racine et ont développé pour cela un exploit de preuve de concept.

Les erreurs se trouvent dans Snap avant la version actuelle 2.54.3. Dans un avis de sécurité, Ubuntu a dressé la liste des paquets mis à jour pour les différentes versions de la distribution. Comme Snap est également proposé par de nombreuses autres distributions, les utilisateurs de Linux devraient utiliser leur gestionnaire de paquets pour rechercher les mises à jour du logiciel et les télécharger et installer rapidement.

Plus d'articles